Home‎ > ‎

Version 3.1

Professional claims compatible with Medisoft version 11sp3 and above. Institutional claims(UB04) compatible with Medisoft version 14 and above.
This is the program to use if you have Medisoft version 17.
 
Included are:
New Look
New Features
 New ERA Autopost feature. The ERA Autopost has been redesigned to allow more flexiblity.
 Support for Medisoft UB04 fields in version 14, 15, 16 and 17.
 
 
Download the latest version here Download
 
For information on ERA Autopost, EMC Secondaries go here Version 3.1 support